G-Irudia 3.9

Date

31/03/2021

Author

b5m

Category

Tools

A new version of G-Irudia (3.9) is now available, and it is compatible with the update of the TLS security protocol of the web b5m. Therefore, if you have had any problem with G-Irudia, uninstall it and install this new version.

Other news

See all the news